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AirSurvey User Manual

AirSurvey User manual
AirSurvey is an easy to use tool to make WiFi coverage site surveys.

www.ermitacode.com
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Getting Started
Optimal coverage in a WiFi network needs a research of the radio strength available in the zones to be provided with the wireless 
service. This information is obtained performing a wireless site survey, revealing dead zones and helping you to find the best 
locations for access points. AirSurvey is an easy to use tool to make WiFi coverage site surveys.
The first time AirView is started the Welcome window will be displayed:

To start a site survey click on Start simple area WiFi survey and enter the data for the area in which the survey will take:

• The Area name.

• Optionally, an Info text.

• The Image that will used as background of the area. Click the  button to select a file containing the image.

Click Add to create the area and set the area dimensions pressing the left button and dragging the mouse to measure a known 
distance on the map:
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In the example, the map dimensions are set by specifying the known measure of a wall. After releasing the mouse, enter the 
dimension of the measure and click the Set button or press Return. The dimensions of the map are calculated in function of the 
measure and shown bellow the map image.
The survey mode is entered, the start survey  button is changed to the  symbol and the cursor is changed to a crosshair 
inside the map:

Locate your actual position in the map and left click in this point to perform a WLAN scanning.
The scanned WLAN’s are stored and graphically displayed in the map:



- 5 -

Repeat this procedure to get several samples in the survey zone and click the  button to finalize the survey.
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Using AirSurvey
The AirSurvey window is divided in two main areas:

The left area shows the actual survey maps. You can organize your survey using 3 types of objects:
• Areas. Contains a single map.
• Buildings. Contains one or several Floors.
• Floors. Contains a single map.

To create a new map object, click the Add + button and select the desired object type in the popup menu.

To remove a map object, select it and click the Remove - button.

You can reorder the map objects using the Reorder buttons located at the bottom of the map list.
Dragging the map objects in the list, it is possible:

• Reorder Areas and Buildings.
• Reorder the Floors of a Building.
• Move an Area to a Building dragging the Area and dropping it into the Building. The Area is then converted to a Floor.
• Move a Floor outside a Building. The Floor is then converted to an Area.

The right area shows the selected Area, Building or Floor heatmap:
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Available controls are:

• Scan. Performs a WLAN scanning.

• Show building. Selects the Building corresponding to the current selected Floor.

• Bellow/above building floor. Selects the Floor bellow or above the current selected.

• Start / Stop survey. Starts or stops the survey mode.

• WLAN filter. Allows selecting the WLAN to be shown in the heatmap. WLAN’s are shown using these symbols:

 represents a SSID (Service Set IDentifier).
 represents a BSSID (Basic Service Set IDentifier).

• Band. Allows filtering BSSID’s by frequency band.

• Edit map. Edit the selected Area, Building or Floor parameters.

• Edit survey configuration. Edit the global survey configuration.

• Print map. Prints the current Area or Floor map.

• Save image. Saves the current Area or Floor map to an image file. 

• Set map dimensions. Permits to establish Area and Floor map dimensions.

• Print survey report. Create and print the survey report document.
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Creating Surveys
You can create a new network database:

• Using the File>New… menu option (keyboard shortcut ⌘N). You will be asked for the new survey name, enter a file 
name and click Save. An empty database file will be created with extension .airsv.

• Using the Welcome panel. The Welcome panel is shown selecting the Window>Welcome to AirSurvey menu option 
(keyboard shortcut ⇧⌘0) or clicking the AirSurvey dock icon when no survey database is open.

To create a new survey database using the Welcome panel:
• Click the Start simple area WiFi survey button to create an empty database file and enter the survey mode. You will be 

asked for the new survey name, enter a file name and click Create.
• Click the Create a new WiFi survey database button to create an empty database file. You will be asked for the new survey 

name, enter a file name and click Create.
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Opening Surveys
Survey information is stored in database files with extension .airsv.
You can open a survey database:

• Using the File>Open… menu option (keyboard shortcut ⌘O).
• Selecting a file name from the File>Open Recent submenu.
• Using the Welcome panel. The Welcome panel is shown selecting the Window>Welcome to NetworkView menu option 

or clicking the AirSurvey dock icon when no survey database is open.

To open a survey database using the Welcome panel:
• Double click a survey database in the file list showing the recent open files.
• Using the Open another network… button.

You can also open a survey using the Finder. AirSurvey document files have the extension .airsv and are shown in the Finder with 
this icon:

To open the file double click the icon or left click to open the icon menu and click Open.
Opening read only AirSurvey documents will cause that all editing and surveying functionalities are disabled. The Read Only 
condition is signaled with a lock icon near the survey database name:
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Saving Surveys
AirSurvey survey databases are automatically saved when they are modified. You do not need to take any special action to save 
survey modifications.

You can save the current survey database contents to a different file using the File>Save As… main menu option (keyboard 
shortcut ⇧⌘S). You will be asked for the new file name, enter a name and click Save.
AirSurvey document files have the extension .airsv and are shown in the Finder with this icon:
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Maps
AirSurvey uses 3 types of objects to manage the maps:

• Areas. Contains a single map.
• Buildings. Contains one or several Floors.
• Floors. Contains a single map.
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Areas
Area objects are used contain single map surveys. For building surveys composed by several floors you can use Building objects 
to group the Floor maps.

To create a new Area, click the Add + button and select  Area in the popup menu or use the Edit>Add>  Area main menu 
option (keyboard shortcut ⇧⌘A):

Enter the Area name, optionally enter a descriptive Info, click the  to select a map Image and click the Add button. The new 
Area map is then displayed and the measure mode is entered to permit you set the Area map dimensions. The descriptive Info 
text is included in the survey report Area page.

To modify an existent Area, click the  button, double click the Area or use the Edit>Edit… main menu option (keyboard shortcut 
⇧⌘E).

 Changing the Area Image will cause that all samples contained in the Area will be lost.
You can move an Area to a Building dragging the Area and dropping it into the Building. The Area is then converted to a Floor.
You can also move a Floor outside a Building and convert it in an Area.

To remove an Area, select it and click the Remove - button or use the Edit>Remove… main menu option (keyboard shortcut 
⇧⌘⌫).
When an Area is selected, the right part of the AirSurvey window will show the Area heatmap:
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Buildings
For a building survey composed by several floors you can use a Building object as a container for the Floor maps.

To create a new Building, click the Add+ button and select  Building in the popup menu or use the Edit>Add>  Building 
main menu option (keyboard shortcut ⇧⌘B):

Enter the Building name, optionally enter a descriptive Info and click the Add button.

To modify an existent Building, click the  button, double click the Building in the map list or use the Edit>Edit… main menu 
option (keyboard shortcut ⇧⌘E).

To remove a Building, select it and click the Remove- button or use the Edit>Remove… main menu option (keyboard shortcut 
⇧⌘⌫).

 Removing a Building will cause that all contained Floors are removed.
When a Building is selected, the right part of the AirSurvey window will show the Building Floors heatmaps:

You can double click a Floor map to select select open it.
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Floors
For a building survey composed by several floors you can use a Building object as a containers for the Floor maps.

To create a new Floor, select a Building, click the Add + button and select  Floor in the popup menu or use the Edit>Add>  
Floor main menu option (keyboard shortcut ⇧⌘F):

Enter the Floor name, optionally enter a descriptive Info, click the  to select a map Image and click the Add button. The new 
Floor map is then displayed and the measure mode is entered to permit you set the Floor map dimensions. The descriptive Info 
text is included in the survey report Floor page.

To modify an existent Floor, click the  button, double click the Floor or use the Edit>Edit… main menu option (keyboard 
shortcut ⇧⌘E).

 Changing the Floor Image will cause that all samples contained in the Floor will be lost.

Dragging the Floors you can reorder them inside of the Building. You can also reorder the Floors using the Reorder  buttons 
located at the bottom of the map list.
If you move an Area to a Building dragging the Area and dropping it into the Building, the Area is then converted to a Floor.
If you move a Floor outside a Building, the Floor is then converted to an Area.
You can also move a Floor to a different Building.

To remove a Floor, select it and click the Remove - button or use the Edit>Remove… main menu option (keyboard shortcut 
⇧⌘⌫).
When a Floor is selected, the right part of the AirSurvey window will show the Floor heatmap:
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You can use the following controls to navigate through the Building Floors:
• Selects the Building corresponding to the current selected Floor.

• Selects the Floor bellow or above the current selected Floor.
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Setting Map Dimensions
Area and Floor map dimensions, in combination with the Sample radius parameter of the survey configuration, are used to 
determine the radius at which the information of the samples taken is significant.
Each time you add a new Area or Floor, the measure mode is entered to permit you set the Area or Floor map dimensions.

You can set the dimensions at any time clicking the ruler  button or using the Edit>Set Map Dimensions… main menu option:

Pressing the left button and drag the mouse to measure a known distance on the map. Release the mouse, enter the dimension of 
the measure and click the Set button or press Return. The dimensions of the map are calculated in function of the measure and 
shown bellow the map image.

To show/hide the map dimensions using the View>Show Map Dimensions main menu option.
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Survey Configuration
Click the  button or use the File>Edit Survey Configuration… main menu option to edit the global survey configuration:

• RSSI threshold. Minimum WLAN RSSI (Received Signal Strength Indicator) to display coverage in the heatmaps.

• Sample radius. Defines the radius at which the information of the samples taken is significant to display in the heatmaps. 
You can select Auto to dinamically adjust the radius from the sample points.
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Scanning WLANs
Click the  button to perform a WLAN scanning:

The following information is shown:

• SSID/BSSID (Service Set IDentifier/Basic Service Set IDentifier).

• Vendor.

• Channel.

• Physical mode.

• Security mode.

• RSSI (Received Signal Strength Indicator).

WLAN’s are shown using these symbols:
•  represents a SSID (Service Set IDentifier).
•  represents a BSSID (Basic Service Set IDentifier).

For example, in the previous figure:

• The SSID rdair contains a single BSSID 20:c9:d0:1a:f0:c1 (the SSID is emitted by 1 Access Point).

• The SSID rdairAC contains 2 BSSID’s cc:d4:a1:83:65:fb and cc:d4:a1:83:66:03 (the SSID is emitted by 2 Access Points).
The WLAN list will be updated with new WLAN’s until it is canceled.

Selecting an WLAN item and clicking Select will set it ad WLAN filter for displaying the heatmaps.
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Performing Surveys
Area and Floor surveys consist of physically traversing the areas to scan the WLAN networks present in various points of these 
areas. The information obtained is then graphically displayed on the map of the Area or Floor by using a heatmap. A heatmap 
represents by colors the RSSI (Received Signal Strength Indicator) measured at each point.

To enter survey mode, click the button or use the Edit> Start Survey main menu option (keyboard shortcut ⌥⌘S). The 
cursor is changed to a crosshair inside the map. You can now traverse physically the Area or Floor locating your position in the 
map and left left click in the corresponding point in the map to perform a WLAN scanning and record the available WLAN’s 
information:

The scanned WLAN’s RSSI information is then graphically displayed in the map:

To stop survey mode, click the  button or use the Edit> Stop Survey main menu option (keyboard shortcut ⌥⌘X).

You can show/hide the map dimensions displayed bellow the map using the View>Show Map Dimensions main menu option.

You can show/hide the sample points and survey path using the View>Show Survey Path main menu option.

You can show/hide the discovered Access Points using the View>Show Access Points main menu option.
You can obtain the WLAN’s information at any point of the map right clicking on it:
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The popover includes the following data:

• SSID (Service Set IDentifier).

• BSSID (Basic Service Set IDentifier).

• Channel.

• Physical mode.

• Security mode.

• RSSI (Received Signal Strength Indicator).

If the selected point matches a sample point, the popover will show the scanned WLAN’s information and at the bottom:
• The date and time the sample was taken.

• A ́ button. You can use this button to remove the sample at any time.

If the selected point does not match a sample point, the popover will show interpolated WLAN’s information.
To select a SSID, a BSSID or the band to be shown in the heatmap you can use the filter popup menus located above the 
heatmap:
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Discovering APs
Using the information obtained in the survey, AirSurvey can automatically determine Access Point locations.

The discovered Access Points can be displayed in the heatmaps using the View>Show Access Points main menu option:
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Saving Map Images
You can easily include network maps in a document saving the view content in an image file and then importing it into your 
document. Alternatively you can copy the map image to the clipboard and paste in your document.

To save the map view to an image file, click  button the or use the File>Save Image… menu option (keyboard shortcut ⌘I).

Available image formats are JPEG, JPEG-2000, PNG, GIF and TIFF.
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Printing Maps
To print an Area or Floor map, click the  button or use the File>Print… menu option (keyboard shortcut ⌘P).

Select the printer and click the Print button or use the PDF menu to print to a PDF file.
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Copying to Clipboard
The pasteboard is a standardized mechanism for exchanging data within an application or between applications via copy and 
paste operations.

Use the Edit>Copy main menu option (shortcut ⌘C) to copy the map image to the clipboard. The image is then available to other 
apps and can be included in your documents. You can also save the map image to a file or print the map. The copied image has 
PNG format.

When the sample popover is shown, use he Edit>Copy main menu option (shortcut ⌘C) to copy the WLAN list to the clipboard.
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Creating Reports
Click the  button or use the File>Print Survey Report… main menu option (keyboard shortcut ⌘R) to generate a report 
document including the survey information:

You can customize the report title, logo, information, copyright and the survey data:

• Report title. Title shown in the cover page and in the page header of the document.

• Logo. Image shown in the cover page and optionally in the page header of the document.

• Show in page header. This option defines if the logo image is included in the page header.

• Info. Text shown in the cover page bellow the logo.

• ©. Copyright text shown in the page footer.

• Include date. This option defines if the date is included in the page footer next to the copyright text.

• WLAN. Use this popup menu to select the SSID or specific BSSID to be included in the report.

• Include single AP heatmaps. If the selected SSID contains several BSSID’s (Access Points), checking this option will 
include a separate heatmap for each BSSID showing the coverage provided by each single AP.

• Include building heatmaps. Checking this option will include building heatmaps showing the coverage in all the floors in a 
single figure.

• Include zones information. Checking this option will include areas, buildings and floors information (info field).

• Show map dimensions. Checking this option will show map dimensions in the heatmaps.

• Show survey paths. Checking this option will show the sample points and survey paths in the heatmaps.

• Show AP locations. Checking this option will show the discovered Access Points in the heatmaps.

You can click the Apply button to save the report parameters without generating the report.

Click Print… to generate the report:
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Select the printer and click the Print button or use the PDF menu to print to a PDF file.
The report includes a cover page and a contents page:

The following figures show an example of an Area, a Building and a Floor heatmap pages:
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The structure of the report documents follows this scheme:

Area1

Area1 - 2.4GHz - Global
Area1 - 2.4GHz - BSSID1
Area1 - 2.4GHz - BSSID2
...
Area1 - 5GHz - Global
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Area1 - 5GHz - BSSID1
Area1 - 5GHz - BSSID2
...

Building1

Building1 - 2.4GHz - Global
Building1 - 2.4GHz - BSSID1
Building1 - 2.4GHz - BSSID2
...
Building - 5GHz - Global
Building - 5GHz - BSSID1
Building - 5GHz - BSSID2
...

Building1 - Floor1

Building1 - Floor1 - 2.4GHz - Global
Building1 - Floor1- 2.4GHz - BSSID1
Building1 - Floor1- 2.4GHz - BSSID2
...
Building1 - Floor1 - 5GHz - Global
Building1 - Floor1- 5GHz - BSSID1
Building1 - Floor1- 5GHz - BSSID2
...

...


