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EAPTest User Manual

EAPTest User manual
EAPTest performs testing of RADIUS servers using common Extended Authentication Protocol (EAP) methods.
The tool implements 3 test modes: Authentication, Accounting and Session tests. For Authentication mode, 3 tests are available:  
Protocol Test, Performance Test and Performance Report. Using the first 3 tests you can see the messages interchanged with the 
authentication server, the Performance tests allow testing server performance under different traffic loads.
EAP methods supported are TTLS, PEAP, MSCHAPv2, MD5 and GTC. For TTLS is possible to use PAP, CHAP, MSCHAP, 
MSCHAPv2, MD5 and GTC as inner methods. For PEAP, the inner methods supported are MSCHAPv2, MD5 and GTC. In addition 
to EAP methods, the PAP protocol is also implemented.

www.ermitacode.com
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Using EAPTest
The left part of the window contains the configurable parameters used perform authentication tests. The right part displays the 
RADIUS protocol messages interchanged with the authentication server.

The parameters are divided in 2 areas:
• Authentication Server: enter the IP address (or DNS name) of the server perform authentication, the Port number used by 

the RADIUS service and the RADIUS Secret configured in the server for this client. The Test connectivity button allows you 
to verify the network connectivity to the server. You can click the  button to manage the RADIUS attributes database 
dictionaries.

• Client: the contents depends on the Test mode selected. For Authentication test mode: the Auth method (PAP and the 
EAP methods TTLS, PEAP, MSCHAPv2, MD5 or GTC) and the Inner authentication method for TTLS or PEAP. Possible 
Inner methods for EAP TTLS are PAP, CHAP, MSCHAP, MSCHAPv2, MD5 and GTC. Available Inner methods for EAP 
PEAP are MSCHAPv2, MD5 and GTC. Enter the credentials (User name and Password) to be authenticated and optionally 
the Out ID (outer identity) sent in tunneled EAP methods (TTLS and PEAP).
For methods using TLS (TTLS, PEAP and TLS) it is possible to select the TLS version:

You can select a specific version (v1, v1.1 or v1.2) or select Max to use the maximum version supported by the 
authentication server.
The different user names used in tests are available for later use in the User name dropdown list:

The user list can be cleared using the Edit>Clear Users main menu option.
Additionally to PAP, the following EAP methods are supported:
TTLS. Inner methods: PAP, CHAP, MSCHAP, MSCHAPv2, MD5, GTC
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PEAP. Inner methods: MSCHAPv2, MD5, GTC
TLS
MSCHAPv2
MD5
GTC

Accounting protocol tests and full session tests can be performed using the Accounting and Session test modes.
Using the buttons bellow the RADIUS attributes you can add an attribute to the list of attributes to be sent in the RADIUS 
messages, remove an attribute or modify an attribute value.
For Authentication mode, bellow the client parameters area is located the Authentication test selection popup menu allowing to 
choose the test mode:

• Protocol Test: observe RADIUS messages interchanged with the authentication server.
• Performance Test: test server performance under different traffic loads.
• Performance Report: compare server performance under different traffic loads.

After defining the authentication parameters and selecting the test mode you can perform the test using the Start Test button. You 
can abort a running test using the Stop Test button. The Clear View button clears the information displayed in the protocol view.
Test parameters including can be saved to a profile for later retrieval. Profiles allow you to have different configurations of test 
parameters and load a specific profile when needed. You can access this functions through the buttons  and  located at the top 
of the window.
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Verifying Connectiviry
To check the network connectivity to the Authentication Server using an ICMP echo request click the ✔ button located to the right of 
the Authentication server IP address.
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Adding RADIUS Attributes
To add a new RADIUS attribute to be sent to the authentication server click the  button bellow the Attributes list.

Select the Vendor, select the attribute name in the Attributes list, enter a Value for the attribute and press the Add button. The 
new added attribute name and value will be shown in the Attributes list.
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Removing RADIUS Attributes
To remove an attribute from the Attributes list select it and click the  button.
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Modifying RADIUS Attributes
To modify the value assigned to a previously added attribute select it in the Attributes list and click the  button.

Enter a new Value for the attribute and press the Set button.
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Test modes
3 test modes are available:
• Authentication. This mode permits displaying the RADIUS authentication messages interchanged with the authentication 

server or test server performance under different traffic loads. 
• Accounting. This mode permits allows to you send RADIUS accounting to the authentication server.
• Session. This mode simulates a complete RADIUS client session by performing authentication, accounting (Start, Updates 

and Stop) and receiving dynamic RADIUS messages (Disconnect and Change of Authorization)-

Mode selection is down using the Test mode selector (see Using EAPTest).
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Authentication Tests
To perform Authentication Tests select Authentication in the test mode selector or select the File>Test>Authentication main 
menu option:

3 Authentication test modes are available using the Authentication test selector:
• Protocol Test.
• Performance Test.
• Performance Report.

To perform Authentication tests you should configure the Authentication method to be used. The following methods are supported:
• PAP
• TTLS
• PEAP
• TLS
• MSCHAPv2
• MD5
• GTC
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Authentication Methods
Authentication tests require an Authentication method to be selected:

The following methods are available:
• PAP
• TTLS
• PEAP
• TLS
• MSCHAPv2
• MD5
• GTC
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Using PAP Method
Select PAP in the in the Auth method popup button. The PAP fields will be shown:

This method will use the specified User name and Password credentials to authenticate.
Yo can clear the las used credentials stored in the User name field using the Edit>Clear Users main menu option.
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Using TTLS Method
Select TTLS in the in the Auth method popup button. The TTLS fields will be shown:

TTLS creates a secure SSL Tunnel to send the user credentials. Inside the Tunnel, the credentials are sent using an Inner 
(tunneled) Authentication Method. This method is selected using the Inner auth popup menu. Supported Inner Methods are: PAP, 
CHAP, MSCHAP, EAP-MSCHAPv2, EAP-MD5 and EAP-GTC.
These Inner methods will use the User name and Password credentials to authenticate.
An Out ID user name can be specified to avoid sending the real User Name in the non secured RADIUS attribute outside the SSL 
Tunnel. The Outer ID field can also be used to specify domain information (for example: anonymous@somedomain.com) to enable 
RADIUS proxying to the remote servers managing external domains.
Yo can clear the las used credentials stored in the User name field using the Edit>Clear Users main menu option.
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Using PEAP Method
Select PEAP in the in the Auth method popup button. The PEAP fields will be shown:

PEAP creates a secure SSL Tunnel to send the user credentials. Inside the Tunnel, the credentials are sent using an Inner 
(tunneled) EAP Method. This method is selected using the Inner auth popup menu. Supported Inner EAP Methods are: EAP-
MSCHAPv2, EAP-MD5 and EAP-GTC.
These Inner methods will use the User name and Password credentials to authenticate.
An Out ID user name can be specified to avoid sending the real User Name in the non secured RADIUS attribute outside the SSL 
Tunnel. The Outer ID field can also be used to specify domain information (for example: anonymous@somedomain.com) to enable 
RADIUS proxying to the remote servers managing external domains.
Yo can clear the las used credentials stored in the User name field using the Edit>Clear Users main menu option.
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Using TLS Method
Select TLS in the in the Auth method popup button. The TLS fields will be shown:

TLS authenticates using a User Digital Identity and sending its Digital Certificate to the RADIUS Server through a TLS session.

To add a Digital Identity to use in the authentication click in the  button and select a PKCS#12 (Personal Information Interchange) 
file. This file should have file PKCS12, P12 or PFX extension. PKCS#12 files are protected by a password which should be entered 
in the file selection panel:

An Out ID user name needs to be specified to send the real User Name in the non secured RADIUS attribute outside the TLS 
session. The Outer ID field can also be used to specify domain information (for example: anonymous@somedomain.com) to enable 
RADIUS proxying to the remote servers managing external domains. To remove the actually used Identity click the  button.

The Identity field shows the Common Name (CN) of the actually used identity and the issuer. Click the  button to open a 
popover showing more information about the digital Identity:

Yo can clear the las used identities stored in the Identity field using the Edit>Clear Identities main menu option.
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Using MSCHAPv2 Method
Select MSCHAPv2 in the in the Auth method popup button. The MSCHAPv2 fields will be shown:

This method will use the specified User name and Password credentials to authenticate.
Yo can clear the las used credentials stored in the User name field using the Edit>Clear Users main menu option.
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Using MD5 Method
Select MD5 in the in the Auth method popup button. The MD5 fields will be shown:

This method will use the specified User name and Password credentials to authenticate.
Yo can clear the las used credentials stored in the User name field using the Edit>Clear Users main menu option.
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Using GTC Method
Select GTC in the in the Auth method popup button. The GTC fields will be shown:

This method will use the specified User name and Password credentials to authenticate.
Yo can clear the las used credentials stored in the User name field using the Edit>Clear Users main menu option.
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Protocol Tests
Authentication Protocol tests generate individual authentication to the authentication server. Protocol messages interchanged with 
the authentication server are show in the right view of the EAPTest window.
To perform protocol tests select Protocol Test in the Authentication test mode selection popup menu or select File>Authentication 
Test>Protocol Test main menu option:

To start the test click the Start button or select the File>Start Test menu option (keyboard shortcut: ⌘R).
To stop an authentication before it has been completed click the Stop button or select the File>Stop Test menu option (keyboard 
shortcut: ⌘T).
During the authentication the right area of the window displays the RADIUS messages being interchanged and the RADIUS 
attributes included in the messages. In the following figure a TTLS/PAP authentication is shown:
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The following messages are shown:
• Access-Request message sent to the server:

• Access-Challenge message received from the server:

• Access-Accept message received from the server:

• Access-Reject message received from the server:

• When the expected message is not received from the authentication server in response to an Access-Request message 
sent, the message is resent several times:
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• If the response timer expires without server response the following indication is shown:

You can stop the authentication using the Stop button or selecting the File>Stop Test menu option.
For SSL based methods (TTLS, PEAP and TLS) a server certificate is sent from the authentication server. This certificate or 
certificate chain is displayed bellow the RADIUS attributes of the message:

To clear the content of the view click the Clear button or select the File>Clear View menu option.
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Performance Tests
Performance Tests performs automatically repeated Performance Tests with different number of concurrent clients to test server 
performance under different traffic loads.

To start an authentication test select Performance Test in the test mode selection popup menu or select the File>Authentication 
Test>Performance Test main menu option:

To start the test click the Start button or select the File>Start Test menu option (keyboard shortcut: ⌘R).
When you select the Performance Test mode the Clients popup menu is displayed. This menu allows you to select the number of 
concurrent requests sent to the authentication server simulating a number of clients performing authentications simultaneously. This 
parameter sets the workload requested to the server and can be modified on the fly during the test.

To stop the test click the Stop button or select the File>Stop Test menu option (keyboard shortcut: ⌘T).
The right area of the window shows 6 elements of performance measurement:

• Authentications strip chart. Shows the number of authentications per second successfully completed (terminated with a 
received Accept or Reject RADIUS message).

• Authentication Failures strip chart. Shows the number of authentication per second failed (some response message from 
the server timed out).

• Authentication Time strip chart. Shows the average of the time spent in successfully completed authentications.
• Average Authentications/second. Shows the current average of all authentications in the test.
• Average Authentication Time in milliseconds. Shows the current average authentication time in the test.
• Authentications request results distribution chart. Shows the current fraction of authentications completed with an Accept 

message, with a Reject message and unsuccessfully terminated (Failures).
In the following figure a TTLS/PAP performance test is shown:
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To clear the content of the view click the Clear button or select the File>Clear View menu option.
You can examine the values of the charts right clicking and dragging on them.
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Performance Reports
Performance Reports performs automatically several Performance Tests with different number of clients to test server performance 
under different traffic loads.

To generate an performance report select Performance Report in the test mode selection popup menu or select the 
File>Authentication Test>Performance Report main menu option:

To start the test click the Start button or select the File>Start Test menu option (keyboard shortcut: ⌘R).

To stop the test click the Stop button or select the File>Stop Test menu option (keyboard shortcut: ⌘T).
The report automatically test server performance in several workload conditions defined by the number of concurrent requests sent 
to the server. The charts show the server behavior when the number of customers (simultaneous requests) increases. The server is 
tested with 1, 10, 20, 30, 40 and 50 simultaneous clients during 5 seconds (total time is 30 seconds).
The right area of the window shows 3 elements of performance measurement:

• Authentications/sec chart. Shows the average number of authentications per second successfully completed (terminated 
with a received Accept or Reject RADIUS message).

• Failures/sec chart. Shows the average number of authentications per second failed (some response message from the 
server timed out).

• Authentication Time chart. Shows the average of the time spent in successfully completed authentications. 
The X axis of all charts is the number of Concurrent Clients.
In the following figure a TTLS/PAP performance report is shown:
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To clear the content of the view click the Clear button or select the File>Clear View menu option.
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Accounting Tests
Accounting tests generate individual accounting requests to the authentication server. Protocol messages interchanged with the 
authentication server are show in the right view of the EAPTest window.
To perform Accounting Tests select Accounting in the test mode selector or select the File>Test>Accounting main menu option:

To start the test click the Start button or select the File>Start Test menu option (keyboard shortcut: ⌘R).
To perform an Accounting Test you should specify a Session ID string and an User name and select the Type of the Accounting 
request message:

• Start
• Stop
• Update (Interim)

To stop the accounting process before it has been completed click the Stop button or select the File>Stop Test menu option 
(keyboard shortcut: ⌘T).
During the accounting process the right area of the window displays the RADIUS messages being interchanged and the RADIUS 
attributes included in the messages:
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The following messages are shown:
• Accounting-Request message sent to the server:

• When the accounting response message is not received from the authentication server in response to the Accounting-
Request message sent, the message is resent several times:

• Accounting-Response message received from the server:

• If the response timer expires without server response the following indication is shown:

To clear the content of the view click the Clear button or select the File>Clear View menu option.
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Session Tests
Accounting tests simulate a complete client session by performing authentication, accounting and listening for dynamic RADIUS 
messages sent by the aythenticationserver. Protocol messages interchanged with the authentication server are show in the right 
view of the EAPTest window.
To perform Session Tests select Session in the test mode selector or select the File>Test>Session main menu option:

To start the test click the Start button or select the File>Start Test menu option (keyboard shortcut: ⌘R).

To terminate the session simulated click the Stop button or select the File>Stop Test menu option (keyboard shortcut: ⌘T).
During the session simulation the right area of the window displays the RADIUS messages being interchanged and the RADIUS 
attributes included in the messages:
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A session test is composed of the following phases:

• Authentication. The client authentication parameters (method, credential and attributes) are defined in the Authentication 
test mode fields. Interchanged messages are displayed as shown in the Authentication Protocol Test section.

• Accounting. If the Authentication phase is terminated with an Accept message from the authentication server, an 
Accounting Start message is sent to the server. The client accounting parameters (session ID and attributes) are defined 
int the Accounting test mode fields. Interchanged messages are displayed as shown in the Accounting Test section.

• Session. The duration of the Session phase is specified using the Session time popup menu. The following values are 
available:

Undefined. The session is maintained until the test is terminated clicking the Stop button or selecting the File>Start 
Test menu option (keyboard shortcut: ⌘R).

1 second. The session is held for 1 second.

5 seconds. The session is held for 5 seconds.

10 seconds. The session is held for 10 seconds.

30 seconds. The session is held for 30 seconds.

During the session, Accounting Update messages can be periodically sent to he authentication server in function to the 
value selected in the Updates popup menu:

No updates. This value disables sending Accounting Update messages.

Send Update every 5 sec.

Send Update every 10 sec.

Send Update every 20 sec.

Send Update every 30 sec.

Send Update every 60 sec.

The Output increment and Input incrementpackets and bytes popups define the increment in the values of the traffic 
counters (Acct-Output-Packets, Acct-Output-Octets, Acct-Input-Packets and Acct-Input-Octets attributes) sent in 
each Accounting Update.
During the session, dynamic RADIUS Disconnect and Change of Authorization (CoA) messages can be received from the 
authentication server. The client port to listen for dynamic RADIUS messages can be configured in the CoA port field.

The behavior for received Disconnect-Request messages is defined by the Disconnect Action popup menu:

Accept Disconnect requests. The received message is acknowledged (a Disconnect-Ack message is sent to the 
server) and the session is ended (the Session end phase is entered).

Reject Disconnect requests. The received message is rejected (a Disconnect-Nak message is sent to the server).

Ignore Disconnect requests. The received message is ignored.

The behavior for received CoA-Request messages is defined by the CoA Action popup menu:

Accept CoA requests. The received message is acknowledged (a CoA-Ack message is sent to the server).

Reject CoA requests. The received message is rejected (a CoA-Nak message is sent to the server).

Ignore CoA requests. The received message is ignored.

The Accounting Updates period, the Output/Input increments and the Disconnect and CoA actions can be modified 
during the session.

• Session end. Session ending is performed sending an Accounting Stop to the authentication server. Interchanged 
messages are displayed as shown in the Accounting Test section.

In the Session phase the following messages are shown:
• Session phase indicator:

• Disconnect-Request received from the server:

• Disconnect-Ack message sent to the server:
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• Disconnect-Nak message sent to the server:

• CoA-Request received from the server:

• CoA-Ack message sent to the server:

• CoA-Nak message sent to the server:

To clear the content of the view click the Clear button or select the File>Clear View menu option.
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Using Profiles
Profiles allow you to save different configurations of test parameters for later retrieval. Test parameters including the attributes and 
the digital Identity used int TLS authentication can be saved to a profile for later retrieval. You can load a specific profile when 
needed.

To save current test configuration to a profile click the  button located at the top of the window or select the File>Save Profile… 
menu option (keyboard shortcut: ⌘S).

To load a profile click the  button located at the top of the window or select the File>Load Profile… menu option (keyboard 
shortcut: ⌘L).

Profiles can be exported and imported.
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Saving Profiles
To save the current test parameters to a profile click the  button or select the File>Save Profile… menu option (keyboard 
shortcut: ⌘S).

In the displayed dialog click the  button to create a new profile:

Enter the profile name and click Save.
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Loading Profiles
To load a profile click the  button or select the File>Load Profile… menu option (keyboard shortcut: ⌘L).

Select a profile and click Load.
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Deleting Profiles
Yo can delete previously saved clicking the  button or selecting the File>Load Profile… menu option (keyboard shortcut: ⌘L).

Select the profile name to delete and click the  button.
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Exporting Profiles
Yo can export a previously saved profile clicking the  button or selecting the File>Load Profile… menu option (keyboard 
shortcut: ⌘L).

Select the profile name to export and click the  button to select the file name to export the profile.
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Importing Profiles
Yo can export a previously saved profile clicking the  button or selecting the File>Load Profile… menu option (keyboard 
shortcut: ⌘L).

Click the  button to select the file containing the profile to import.
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Saving to an Image File
If you need to include a test result in a document, you can save the results view (the RADIUS messages interchanged during an 
authentication in Authentication Test mode, or the performance information in Performance Test and Report modes) to an Image 
File and then import it into your document. To save the view to an Image File click the File>Save Image… menu option.

Available Image Formats are JPEG, JPEG-2000, PNG, GIF and TIFF.
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Printing
To print the results view (the RADIUS messages interchanged during an authentication in Authentication Test mode, or the 
performance information in Performance Test and Report modes) click the File>Print… menu option.

Select the printer and press the Print button or use the PDF menu to save a PDF copy to the disk.
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Managing Dictionaries
To manage the RADIUS attributes database use the File>Manage Dictionaries... menu option or click the  button in the Server 
parameters area:

The window shows the the left list all the dictionaries actually contained in the database. When a dictionary item is selected in the 
list, information about the dictionary is shown in the right part of the window: the Vendors for which some attributes or values are 
defined in the dictionary and the number of Attributes and Values defined in the dictionary.
Using the buttons bellow the Dictionaries list you can:

Import Dictionary Files

Remove Dictionaries

Reset the Dictionary Database
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Importing Dictionaries
To import a dictionary file to the RADIUS attributes database click the  button in the Manage Dictionaries window.
Select the dictionary file in the displayed file dialog and press the Open button.
The new imported dictionary will be shown in the Dictionaries list in the Manage Dictionaries windows.
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Removing Dictionaries
To remove a dictionary from the RADIUS attributes database select it in the Dictionaries list and click the  button in the Manage 
Dictionaries window.

Press the Delete button in the displayed alert.
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Resetting the Database
To reset the RADIUS attributes database to the default dictionaries click the button in the Manage Dictionaries window.

Press the Restore button in the displayed alert dialog.
The stablished default dictionaries are:
• RFC2865

• RFC2866
• RFC2868
• RFC3162

• RFC3576
• Microsoft

• Cisco
• Aruba


